Author Topic: Stuck on China Adventure "Baking The Keystone"  (Read 2327 times)

Offline Marc3070

  • NPC
  • *
  • Posts: 2
Stuck on China Adventure "Baking The Keystone"
« on: June 14, 2017, 05:34:33 PM »
Hello Community!

I have decided to create a user inhere, out of sheer desperation.

I am Stuck on the China Adventure quest "Baking the keystone", where i have to bring a heart shaped keystone to two locations (Phoenix Martial Arts Academy, and the Scholars Garden), while the keystone was in my inventory.

It won't trigger completion!! :'(

Things i have done so far:
- walk to both locations, during day and night time.
- same procedure while running.
- tried 'Zeneporting' to both locations separately, and from one place to another.
- tried giving the keystone to the 'quest person' as a gift (resulted in me failing the quest, and destroying the keystone).
-spending extended amounts of time at the garden & academy
-training at training academy
-Meditating at the garden
-resetting my sim, and the whole town

Nothing has worked, and i am at the point where the tears of frustration are making themselves present.

I have read various guides about all quests in china (including Carl's sims 3 guide, gamefaqs guide, fandom powered wikia guide, and i even tried translating a korean and thai guide to no avail).

I have also seen the previous post from august 26'th 2016 on the issue, but resetting the sim [resetsim (firstname) (lastname)] didn't work for me, which is why i made a user here in hope of getting additional assistance.

Is there any way i can trigger the quest complete by using console commands, or skip to the next part of the china adventures questlines ('A curious note' starts dong huo's adventure chain) with completing this one?

My current martial arts level is 8 - and i bought i house in Shang Simla (china) after trying all this.

Any assistance would be greatly appreciated!!

Offline MrsFlynn

  • Admin Assistant
  • Administrator
  • Watcher
  • ******
  • Posts: 5267
Re: Stuck on China Adventure "Baking The Keystone"
« Reply #1 on: June 14, 2017, 06:08:22 PM »
It sounds like you've tried reset sim, but have you tried maybe evicting household and moving them back in?

Something else worth trying is a factory reset. I do this any time my game starts acting odd. I can't promise these will help, but they are worth considering.

Links to details about both these options are below:

Reset Town, Individual Sims and/or Evict Household
http://www.carls-sims-4-guide.com/forum/index.php?topic=20732.msg401812#msg401812

Sims 3 Factory Reset (What & Howto)
http://www.carls-sims-4-guide.com/forum/index.php?topic=20732.msg401814#msg401814

New Members, Welcome!! We hope you enjoy the forum!!  Thank you for visiting!!
Need Help? Check our Member FAQs Here. * -- Read and follow the Forum Rules, please! *



Registered members do not see ads on this Forum. Register here.

Offline emilyplayssims

  • NPC
  • *
  • Posts: 4
Re: Stuck on China Adventure "Baking The Keystone"
« Reply #2 on: November 13, 2017, 01:48:38 AM »
I think your best bet here would be to cancel the quest and keep flipping through adventures until it recirculates back to you. That's a total bummer that it won't let you complete it, as that part of the quest is so ridiculously simple! Good luck!

Offline prosimmer

  • NPC
  • *
  • Posts: 1
Re: Stuck on China Adventure "Baking The Keystone"
« Reply #3 on: April 13, 2020, 01:54:57 PM »
I were also stuck at that adventure and tried these:

- ctrl + shift + c => in console typed => resetsim *
- canceled the quest and after a time retrieved again - go at it again

did not work for me. Also looked for a solution in the internet and could not found one. After a time I solved the issue by myself (I don't know if this will work out for you but give it a try)

I did these but I don't know which one worked so I will write all of it:

At start typed resetsim * then I gifted away the heart shaped keystone and failed the quest - maybe cancel the quest both can be same.

After that go to edit town and make a copy of both garden & academy and after copying them delete them.

After deletion make their areas available to public visiting.

Place the copies to their places - actually I switched their locations with each other when placing.

Then go to quest board and continue like normal.

Hope it will solve someone's problem and sorry for bad english.

P.S. This also solved the Pilgrims Walk quest's problem.

 

anything