Author Topic: How to fix the "flat" grass: without Advanced Rendering  (Read 19085 times)

Offline TheChronicR

  • Watcher
  • ******
  • Posts: 5964
How to fix the "flat" grass: without Advanced Rendering
« on: June 07, 2011, 03:16:28 PM »
Have you ever wondered why your grass looks "flat": not detailed, fake? Well, there is a reason why it looks different. The solution is in game options, you should turn Advanced Rendering on, in addition change some Graphic settings. As you realize, this will slow down your game quite a lot. But you do want the grass to look nice, don't you?

There is a way of fixing the problem without Advanced Rendering.

Here are the instructions by Rockermonkey999, posted on the official forums. It requires tweaking a system file, so you may use it at your own risk. Also, before patching you need to undo everything. I recommend to backup your "The Sims 3" folder (found in (My) Documents/Electronic Arts) before the process, in case you mess up anything. It's simple, but still.

In case the official site is down for maintenance, I'm posting the instructions here too.

Quote
- Go to your latest EP/SP folder.
 - Go to Game, and then Bin.
 - Find the GraphicRules.sgr file, make sure to back it up(for if something goes screwy, or there's a new patch).
 - Open the original file with Notepad.
 - At the top of the window press Edit, and then Find. Type in 'advanced'
 - It will be the first click. It should read:

 option AdvancedRendering
 setting $Off
 prop $ConfigGroup RenderForceMinspecShaders 1
 prop $ConfigGroup TerrainLODMode 1
 prop $ConfigGroup RenderPostProcessEnabled false
 prop $ConfigGroup RenderShadowsEnabled false
 prop $ConfigGroup CullUndergroundBuildBuyStructures 0
 setting $On
 prop $ConfigGroup RenderForceMinspecShaders 0
 prop $ConfigGroup TerrainLODMode 0
 prop $ConfigGroup CullUndergroundBuildBuyStructures 0

 The 1 that I bolded will be turned into a 0, in the end it should look like this:

 option AdvancedRendering
 setting $Off
 prop $ConfigGroup RenderForceMinspecShaders 1
 prop $ConfigGroup TerrainLODMode 0
 prop $ConfigGroup RenderPostProcessEnabled false
 prop $ConfigGroup RenderShadowsEnabled false
 prop $ConfigGroup CullUndergroundBuildBuyStructures 0
 setting $On
 prop $ConfigGroup RenderForceMinspecShaders 0
 prop $ConfigGroup TerrainLODMode 0
 prop $ConfigGroup CullUndergroundBuildBuyStructures 0

 Save it, and you're done!
Well, that's your opinion, isn't it? And I'm not about to waste my time trying to change it. - Lady GaGa

Offline TheChronicR

  • Watcher
  • ******
  • Posts: 5964
Re: How to fix the "flat" grass: without Advanced Rendering
« Reply #1 on: July 28, 2011, 11:57:50 AM »
I got a few people telling me that they are having problems whilst trying to edit the file. There is a workaround for this:

1) Make sure to back up the original GraphicRules.sgr file, as noted in the first post.
2) Somewhere else, not where you backed it up, right-click and select "Paste".
3) Edit the pasted file. (the second one, not the backed up one)
4) When you're finished, replace the original GraphicRules.sgr with this, edited file.
5) That's all!
Well, that's your opinion, isn't it? And I'm not about to waste my time trying to change it. - Lady GaGa



Registered members do not see ads on this Forum. Register here.

Offline TheChronicR

  • Watcher
  • ******
  • Posts: 5964
Re: How to fix the "flat" grass: without Advanced Rendering
« Reply #2 on: July 28, 2011, 11:59:00 AM »
Also, in case all else fails and even this method doesn't help, I guess you'll have to turn on Advanced Rendering to get "good" grass. If that doesn't help too, then it's your graphic cards. :-\
Well, that's your opinion, isn't it? And I'm not about to waste my time trying to change it. - Lady GaGa

Offline PJSim

  • Immortal
  • *****
  • Posts: 750
  • It's a girl!
Re: How to fix the "flat" grass: without Advanced Rendering
« Reply #3 on: July 28, 2011, 12:10:46 PM »
1) Make sure to back up the original GraphicRules.sgr file, as noted in the first post.

If you forget to do this backup it's not a problem. That file can be found on the game disk so you can just restore it from there if needed.

Offline TheChronicR

  • Watcher
  • ******
  • Posts: 5964
Re: How to fix the "flat" grass: without Advanced Rendering
« Reply #4 on: July 28, 2011, 12:29:18 PM »
If you forget to do this backup it's not a problem. That file can be found on the game disk so you can just restore it from there if needed.

Oh, thanks for that. Never knew. :)
Well, that's your opinion, isn't it? And I'm not about to waste my time trying to change it. - Lady GaGa

Offline Deppy

  • NPC
  • *
  • Posts: 3
Re: How to fix the "flat" grass: without Advanced Rendering
« Reply #5 on: July 17, 2018, 10:21:56 PM »
Hello , thank you for your post ! It was the best solution I could find all day ! I tried it out and it worked ! My game is as smooth as it gets and the terrain isn't blurry anymore ! BUT a new problem emerges as now all the previously green grass has turned brown !! When I am in town view I can see the normal green color but when I zoom in to actually play the previously green blurry grass is now detailed and brown .. what can I do  It's really distracting ! Especially the change when going from town to normal view . Any suggestions ? :(

Offline BubbsArt

  • Nooboo
  • *
  • Posts: 5
Re: How to fix the "flat" grass: without Advanced Rendering
« Reply #6 on: September 29, 2018, 04:35:00 PM »
Very insightful.



Registered members do not see ads on this Forum. Register here.