Author Topic: Lost Items  (Read 848 times)

BerniniCaCO3

  • Guest
Lost Items
« on: August 22, 2011, 12:01:29 AM »
My blacksmith just spent a goodly amount of time collecting mithral and mana stone to craft darkstone armor and an excalipaddle for my spy; also 2 manaswords.
My smith found the king, gave him a sword; then tried the pigeon post to request a meeting, then did a quest step, then wandered back to the village square and found the spy.

At this point, I still had the other manasword, but the darkstone armor and the paddle were gone.  My sim still had her own excalipaddle, but not the second; and no armor.  I tried moving materials into the forge storage, in case your inventory has a max size, but nope, nada.

Any ideas-- anything normal that I could have done?  Anywhere I could have accidentally dropped or stored them?  
Or chalk it up to a tragic bug, and make new ones another simday....


...btw, is there any way to change a hero sim's name, like you can in sims 3 by going to the town hall?