Author Topic: All mods and families disappeared (Mac)  (Read 302 times)

Offline Ariel1654

  • NPC
  • *
  • Posts: 1
All mods and families disappeared (Mac)
« on: September 12, 2018, 06:37:19 PM »
Alright so Sims and origin was having some issues on my mac. I couldn't update my game. After talking to the help center I was able to update my game by updating my mac to the latest version. All was well. Till my mac did something slightly weird and forced me to deal with siri and the cloud (these were apparently new features for my mac).

Anyways I was forced to do it and it made it so all my files were sent to cloud without my permission.

After this happened I went to play sims. I had to resign into my origin account and the first time I tried to start my sims game it shut down with a message that it currently could not be accessed. I tried again and the game was able to start.

However, all my houses and content in my library was deleted along with my mods and cc. I quit the game and went to check my mods folder to see if all my downloads were there. They were. So then I tried to right click on one of my downloads to open it in application. When I was given options to open the content with, my old Sims 3 game was available to do so (was not greyed out) but my Sims 4 game was greyed out and unclickable.

Ps I had already previously gone into game options to ensure my mods were enabled. When I checked to see custom content/mods (because you can bring up a list in options as well) none of my downloads were in that list it was blank. I have played sims for a while and know that on every update it disables your mods but this was not the case.

Anyways, I tried a number of different options I researched to save my games and save my mods. I tried repairing the game in origin (and yes I did take my mods folder out and deleted local cache and cache).

I tried restarting my laptop multiple times. I even went so far as to completely undownload origin and redownload it again followed by redownloading my sims 4 games (twice). I finally got so frustrated knowing that my previous work (over 400 hours spent on these houses I have a fricken family lineage going on with 6 generations!) and cc/mods were not going to work. So I deleted my mods folder. Created a new one and tried to add some new cc. The cc is in the folder but still is not appearing in the game. And once again when I try to open the downloads by right clicking and selecting open with application, sims 4 is still not an option. PPS before I repaired and got new mods and everything else, I disconnected my files from cloud.

All my families are gone. Mods and ccs are no longer working (even though they used to). I read another post by someone who posted a couple yrs back with the exact reasoning but someone had replied that the sister was lying as files in the tray folder cannot be deleted. And mine weren't. I still am seeing the files of my saved households. But like the cc they are not appearing in the actual game. Its like my folders and my games have been disconnected. I also right clicked the game in origin did advanced setting and there "-mods" was not written in commands. There was nothing in commands. Please help.

Offline MrsFlynn

  • Admin Assistant
  • Administrator
  • Watcher
  • ******
  • Posts: 5087
Re: All mods and families disappeared (Mac)
« Reply #1 on: September 12, 2018, 07:28:48 PM »
To be able to find families, you may need to search any save files you have and search through each saves' Manage households.

Read more in the post linked below:

Families Keep Getting Deleted
http://www.carls-sims-4-guide.com/forum/index.php?topic=29389.msg473904#msg473904

You might want to have a look through the Mac Help post from the AHQ forum. If none of it helps, report your issue on the AHQ Sims Mac Forum also linked below:

Sims 4 - Mac Help, Guides and Troubleshooting
https://answers.ea.com/t5/The-Sims-Mac/READ-FIRST-Sims-4-Mac-Help-Guides-and-Troubleshooting/td-p/4612394

AHQ Sims Mac Forum
https://answers.ea.com/t5/The-Sims-Mac/bd-p/The-Sims-Mac
New Members, Welcome!! We hope you enjoy the forum!!  Thank you for visiting!!
Need Help? Check our Member FAQs Here. * -- Read and follow the Forum Rules, please! *



Registered members do not see ads on this Forum. Register here.

 

anything