Author Topic: Bug Thread for Server Move  (Read 3112 times)

Online Carl

  • Webmaster
  • Administrator
  • Watcher
  • *****
  • Posts: 3753
    • Carl's Sims 4 Guide
Re: Bug Thread for Server Move
« Reply #25 on: July 20, 2014, 01:35:36 PM »
I myself was just logged out from the cookie thing, so I'm afraid your problem may be back, symphonicanima. Let me know.

I think it's possible emails are being received now. My test account just got its confirmation email reminder. I just set up an account with a provider that lets me send thousands of emails per month, without bogging down our server. The price is worth it for reliable sending. So let me know, else I need to get on more configuration.

Online Carl

  • Webmaster
  • Administrator
  • Watcher
  • *****
  • Posts: 3753
    • Carl's Sims 4 Guide
Re: Bug Thread for Server Move
« Reply #26 on: July 20, 2014, 02:24:24 PM »
Mods and myself are getting Notifications, so all is well with the email system :)

Now the only thing that I know of as an issue is potential problems for mobile users who are getting logged out, as symphonicanima described. When I use the other option in config, we are all subject to log out and telling people to use cookies constantly would be a pain. I am hoping that issue is still fixed for you, but will investigate further if it's not. I can't promise it's anything I can even fix though, given it could have something to do with security settings.  Sometimes phones won't even let you change those within their browsers.. in fact, I'm sure most don't.



Registered members do not see ads on this Forum. Register here.

Offline smartburn

  • Occult
  • ****
  • Posts: 321
Re: Bug Thread for Server Move
« Reply #27 on: July 20, 2014, 02:29:40 PM »
Good to know about the cookie thing, I might enable them for this site if that helps.

I had to log in twice within the last 16hrs or so - the first time it was set to "forever", but this recent login listed 60min as the default and didn't provide any other options under a drop-down menu. I didn't try changing the number of minutes though. Anyway, no big whoop, luckily this site has one of the passwords I can remember. :P

Online Carl

  • Webmaster
  • Administrator
  • Watcher
  • *****
  • Posts: 3753
    • Carl's Sims 4 Guide
Re: Bug Thread for Server Move
« Reply #28 on: July 20, 2014, 02:36:10 PM »
Tried changing a setting that affects when a session times out, that makes it more like 6 hours, which should help. This is different from the option you  get when logging in and may be the cause. It was also set to 60 minutes. I myself hate these logout issues, and it happens when going from carls-sims-3-guide.com to www.X  as they count as two different servers. Given the domain has propagated for most people now, I felt comfortable to force us all back to www.carls-sims-3-guide.com for consistency.

Offline symphonicanima

  • Nova Salerix
  • Llama Wrangler
  • **
  • Posts: 55
  • Origin ID: symphonicanima
Re: Bug Thread for Server Move
« Reply #29 on: July 20, 2014, 03:42:45 PM »

I myself was just logged out from the cookie thing, so I'm afraid your problem may be back, symphonicanima. Let me know.

I just realized that I had set Safari to never accept cookies instead of from visited- whoops! I changed my settings back for that and played around to test it, the logout issue doesn't appear to be coming back. Sorry for the trouble from my oversight, Carl. :( Though, I think the issue really might be allowing browsers to store cookies, though I'm not certain of the validity of this theory since I don't know too much about it.

Still, it appears that storing cookies on the server for such a large amount of Forum members really does seem inefficient...

Online Carl

  • Webmaster
  • Administrator
  • Watcher
  • *****
  • Posts: 3753
    • Carl's Sims 4 Guide
Re: Bug Thread for Server Move
« Reply #30 on: July 20, 2014, 05:21:40 PM »
Yeah, it's inefficient though not a burden. I think that if turning on storage helped you now, then the Forum must be saving on both ends. Thankfully, it's not a major thing disk-space wise, which is the only consumption involved - even with 10x the members, we'd be fine with this setting. Either way, glad your problem didn't come back! That's great, as it means many others out there won't have this issue in the future, and we know what to say if they do.

Offline KhaineGB

  • Immortal
  • *****
  • Posts: 744
Re: Bug Thread for Server Move
« Reply #31 on: July 20, 2014, 08:04:14 PM »
Got auto-logged out on my laptop (Windows 7, Google Chrome, cookies set to store locally).

To be fair, I checked the site about 10am and just now (1am), so something might have changed. My phone logs me out all the time (I use Google Chrome on that too rather than Tapatalk).



Registered members do not see ads on this Forum. Register here.

Online Carl

  • Webmaster
  • Administrator
  • Watcher
  • *****
  • Posts: 3753
    • Carl's Sims 4 Guide
Re: Bug Thread for Server Move
« Reply #32 on: July 20, 2014, 08:30:49 PM »
And this is with the browser remembering the password, or not? With that on, every time I visit here I'm always logged in. However, since 10am I forced all visits to go to www.carls-sims-3-guide.com where it was originally pointing to non-www.  Also, I changed the cookie name so it may require you to have the new one in place (this should happen automatically). Maybe one of those is the difference that caused the issue. Let me know how it goes.

I don't think the login forever is really meant to always detect your pc and auto-log you without a password, though that sure seems to be what it implies when we choose 'forever'.  I am not 100% clear on the mechanics of that though, as I've never researched them in-depth. It just seems to be a bad idea to make forever the default when someone might log in at a library or something, if it were really going to treat it that way. I think the session could expire with the browser open (inactivity), if you chose 1 hour, whereas forever would prevent the session from expiring with only the browser closing causing it to expire.

Offline KhaineGB

  • Immortal
  • *****
  • Posts: 744
Re: Bug Thread for Server Move
« Reply #33 on: July 20, 2014, 08:50:41 PM »
That could be it then.

Yes, both browsers set to remember passwords and cookies. I'm about to go to bed (2am, at a metal festival all day, absolutely exhausted!) so I'll monitor it tomorrow and report back :)

EDIT: I think "forever" is supposed to set a non-expiring cookie, whereas other options will set them to expire after X amount of time. At least that's how it was explained to me... oooooh... 12-14 years ago. So I might be mis-remembering.

Online Carl

  • Webmaster
  • Administrator
  • Watcher
  • *****
  • Posts: 3753
    • Carl's Sims 4 Guide
Re: Bug Thread for Server Move
« Reply #34 on: July 20, 2014, 08:58:03 PM »
EDIT: I think "forever" is supposed to set a non-expiring cookie, whereas other options will set them to expire after X amount of time. At least that's how it was explained to me... oooooh... 12-14 years ago. So I might be mis-remembering.

There we have it, a great explanation. Thanks.

Offline JudesSims

  • Sim Addict - and Proud of It!
  • Watcher
  • ******
  • Posts: 2519
Re: Bug Thread for Server Move
« Reply #35 on: July 20, 2014, 10:51:22 PM »
I don't know is this is a server issue or not but...when someone quotes someone else's post, TapaTalk shows the code with the quote. This is only happening with my ipad not my iPhone. I thought I should tell you just in case it's important to you.

Online Seabody

  • Global Moderator
  • Watcher
  • ******
  • Posts: 5088
Re: Bug Thread for Server Move
« Reply #36 on: July 21, 2014, 03:01:55 AM »
My phone logs me out all the time (I use Google Chrome on that too rather than Tapatalk).

I think that's some sort of issue with Chrome. I get exactly the same thing too sporadically. Just constant refreshing helps. ;)

I don't know is this is a server issue or not but...when someone quotes someone else's post, TapaTalk shows the code with the quote. This is only happening with my ipad not my iPhone. I thought I should tell you just in case it's important to you.

Obviously I'm not Carl ( ;) ) but it sounds like an issue with TapaTalk if it's only happening on your iPad. :)

Online Carl

  • Webmaster
  • Administrator
  • Watcher
  • *****
  • Posts: 3753
    • Carl's Sims 4 Guide
Re: Bug Thread for Server Move
« Reply #37 on: July 21, 2014, 08:36:25 AM »
They recommend reinstalling tapatalk to correct that, so I'm working on it.

Edit: No way for me to tell right now if that worked. You'll have to let me know.

Online Carl

  • Webmaster
  • Administrator
  • Watcher
  • *****
  • Posts: 3753
    • Carl's Sims 4 Guide
Re: Bug Thread for Server Move
« Reply #38 on: July 21, 2014, 09:17:24 AM »
Ahhh.. it feels really good to knock out the last problem on my end - comments causing a hanging page that would make a person think their comment wasn't received. At that, I was able to reopen comments on the Sims 3 Guide as well as my Civ 5 Strategy Site.  If tapatalk isn't working, I'll be able to test it tomorrow with my kindle and see if I can get it working 100% correctly. 

Thank you all for your patience. I know it's been a bumpy ride this past weekend, but I believe I am done now. It was definitely worth it to give us some room to grow, as well as possibly preventing us from being overwhelmed when The Sims 4 launches.

Offline JudesSims

  • Sim Addict - and Proud of It!
  • Watcher
  • ******
  • Posts: 2519
Re: Bug Thread for Server Move
« Reply #39 on: July 21, 2014, 10:31:37 AM »
A reinstall of TapaTalk fixed the issue!

Online Carl

  • Webmaster
  • Administrator
  • Watcher
  • *****
  • Posts: 3753
    • Carl's Sims 4 Guide
Re: Bug Thread for Server Move
« Reply #40 on: July 21, 2014, 01:53:28 PM »
Oh my, that's a relief... because if it hadn't, I would have had to do some configuration on the server - those should be easy to install :) Thanks for letting me know.

Offline KhaineGB

  • Immortal
  • *****
  • Posts: 744
Re: Bug Thread for Server Move
« Reply #41 on: July 21, 2014, 06:40:03 PM »
Just had a popup to download img.php.

That's... not very normal. ;)

Online Carl

  • Webmaster
  • Administrator
  • Watcher
  • *****
  • Posts: 3753
    • Carl's Sims 4 Guide
Re: Bug Thread for Server Move
« Reply #42 on: July 21, 2014, 06:54:44 PM »
What were you doing when this happened? Has this happened to anyone else? It sounds like a parsing error but in order to know where to look for a problem, I'd need to know the forum activity that caused it.

However, it could simply be a bad ad unit (all members have the bottom ad) that caused it to offer to download, rather than use img.php to render the advertisement. If you get that (and it's a real download obviously from the forum), then do download, don't open, and email/attach it to [email protected] so I can investigate further.

Hopefully it was an isolated incident.

Offline KhaineGB

  • Immortal
  • *****
  • Posts: 744
Re: Bug Thread for Server Move
« Reply #43 on: July 21, 2014, 06:59:09 PM »
Literally booted up the laptop, opened chrome and navigated to the forum home page.

Offline KhaineGB

  • Immortal
  • *****
  • Posts: 744
Re: Bug Thread for Server Move
« Reply #44 on: July 22, 2014, 01:46:48 AM »
Just a small one.

The tapatalk icon doesn't show in "Who's Online" anymore. :)

EDIT: Also in Who's Online, the Yahoo! Instant Messenger icon is gone as well.

Online Carl

  • Webmaster
  • Administrator
  • Watcher
  • *****
  • Posts: 3753
    • Carl's Sims 4 Guide
Re: Bug Thread for Server Move
« Reply #45 on: July 22, 2014, 03:07:20 PM »
They update rather frequently, so I'm hoping to have that fixed, along with the fact that there's no tapatalk section in my admin panel. It's not their fault, our Forum is just heavily customized with plugins, so it doesn't know what to do on certain files. I'll get it corrected, hopefully, on the next update.

Offline KhaineGB

  • Immortal
  • *****
  • Posts: 744
Re: Bug Thread for Server Move
« Reply #46 on: July 22, 2014, 04:04:38 PM »
Ok! It's only a cosmetic thing, but wanted to make sure you knew :)

Online Carl

  • Webmaster
  • Administrator
  • Watcher
  • *****
  • Posts: 3753
    • Carl's Sims 4 Guide
Re: Bug Thread for Server Move
« Reply #47 on: July 22, 2014, 05:15:14 PM »
Always appreciate that - I didn't know myself, and I need to know of every little problem so that I can possibly fix it. Thanks to everyone who participated in this thread, we are running pretty smoothly right now.

Offline grimsoul

  • Watcher
  • ******
  • Posts: 1640
Re: Bug Thread for Server Move
« Reply #48 on: July 22, 2014, 09:45:51 PM »
Sense the server change the site will load fast for a few pages then I'll try to open a page and it just sits there trying to load and never does. I can usually leave the site for a few minutes and come back and everything will be fine again for 3 or 4 pages then it gets stuck again.
This is happening to me in both Firefox version 31 and Internet Explorer 11. I never had this problem until the last few days. I thought it would straighten out after the move was complete but so far it hasn't.
Has anyone else been having this problem?
A clear conscience is usually a sign of a bad memory.

Offline KhaineGB

  • Immortal
  • *****
  • Posts: 744
Re: Bug Thread for Server Move
« Reply #49 on: July 23, 2014, 01:17:27 AM »
Only when using my WiFi. When direct-wired to my router, I'm fine.

But when the problem does start, it is only these forums. Facebook and other things still work fine.