Author Topic: FPS  (Read 6791 times)

Offline SamPlaysSimGames

  • Nooboo
  • *
  • Posts: 17
« on: September 25, 2016, 03:03:05 PM »
So, I've been having problems with The Sims 4 ever since I installed Windows 10 last year. (In live mode) Sometimes the FPS would be 60 fps, then If I go on it again the FPS would be in the 10's or 20's, and making it really laggy and last enjoyable for me, I've spoke to EA support countless times and done everything they told me to do, from repairing the game to updating my drivers (I have no CC or mods) I was wondering if anyone can help me with this?

Offline MrsFlynn

  • Admin Assistant
  • Administrator
  • Watcher
  • ******
  • Posts: 5076
Frames Per Second (FPS) Tips
« Reply #1 on: September 25, 2016, 03:20:24 PM »
Frames Per Second (FPS) Tips

Try not to put a whole lot of focus on the FPS as the end-all-be-all of your game play. Unless you are noticing a problem, it's best to turn on V-Sync and enjoy your game. Checking the FPS will drive you crazy because this game fluctuates so much and there is nothing that can be done to really fix it. Specially for Sims, which isn't optimized very well and has a quirky game engine.

Please note it's normal for the game and it's camera to have some stuttering when zooming in/out and scrolling around, even with having better graphics cards due to the way the game has been optimized.

Whenever you play any kind of 3D game, or use a visually demanding application, it's fairly typical that your computer will get louder as the fans speed up to keep up the needed cooling. :)

You can try a game booster, or an Fps Limiter, but they may or may not work well either.

Read the link below for information on a fps limiter.

Sims 4 fps limiter?

Can we talk about the Sims 4 and frame rate

However, it's mentioned in the thread linked below that there is a known FPS dropping bug that's been around since 2015. A lot of Simmers are getting drop into the 40's when zoomed out.

Sims 4 FPS Drops

I went into game to test this and found we were getting dropping into the 40s as well when zooming in and out.

Limit FPS (In-Game as well as using the Nvidia Control Panel)

If you have an Nvidia graphics card you could tweak the settings

Nvidia Control Panel Settings
1. Right click on the desktop and select NVIDIA Control Panel.
2. Select Manage 3D Settings.
3. Select Program Settings tab.
4. Click Add.
5. Select The Sims 4 and click Add Selected Program.
6. Choose the preferred graphics processor to use from the drop menu and select High-Performance NVIDIA Processor.

I did a quick search on tweaking the FPS on Sims 4 and found this guide that might help.

Performance Boost Guide

Can someone help me understand FPS?

Limit FPS in the Options.ini file
You can limit the FPS in Documents ╗ Electronic Arts ╗ The Sims 4 ╗ Options.ini. There is line that says "frameratelimit". That you can set to whatever you like, 30, or 60... 60 is the best.
New Members, Welcome!! We hope you enjoy the forum!!  Thank you for visiting!!
Need Help? Check our Member FAQs Here. * -- Read and follow the Forum Rules, please! *

Registered members do not see ads on this Forum. Register here.

Offline SamPlaysSimGames

  • Nooboo
  • *
  • Posts: 17
« Reply #2 on: September 25, 2016, 05:49:37 PM »
The lag doesn't happen time to time in one gaming session. For example, I would play the game for 20 minutes and exit the game (with the FPS being in the 60's) and if I play on it again later on in the day, the FPS wouldn't be in the 60's, it would be in between the 10 - 20's.